Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000127 [Resin] minor always 04-28-05 00:00 11-01-05 14:44
Reporter ferg View Status public  
Assigned To
Priority high Resolution fixed  
Status closed   Product Version 3.0.12
Summary 0000127: EJBCompiler issue
Description RSN-118
(rep by Kirk Rasmussen)

Apr 26, 2005 11:43:50 PM com.caucho.ejb.xa.EjbTransactionManager <init>
WARNING: javax.naming.NoInitialContextException: Need to specify class name in environment or system property, or as an applet parameter, or in an application resource file: java.naming.factory.initial
javax.naming.NoInitialContextException: Need to specify class name in environment or system property, or as an applet parameter, or in an application resource file: java.naming.factory.initial
            at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:645)
            at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:247)
            at javax.naming.InitialContext.getURLOrDefaultInitCtx(InitialContext.java:284)
            at javax.naming.InitialContext.lookup(InitialContext.java:351)
            at com.caucho.ejb.xa.EjbTransactionManager.<init>(EjbTransactionManager.java:106)
            at com.caucho.ejb.EnvServerManager.<init>(EnvServerManager.java:147)
            at com.caucho.ejb.EnvServerManager.createLocal(EnvServerManager.java)
            at com.caucho.ejb.EjbServerManager.<init>(EjbServerManager.java:142)
            at com.caucho.ejb.EjbServerManager.createLocal(EjbServerManager.java)
            at com.caucho.ejb.EJBCompiler.compile(EJBCompiler.java:113)
            at com.caucho.ejb.EJBCompiler.main(EJBCompiler.java:147)
Exception in thread "main" java.lang.RuntimeException: com.caucho.config.ConfigException: Can't load TransactionManager.
            at com.caucho.ejb.EnvServerManager.<init>(EnvServerManager.java:155)
            at com.caucho.ejb.EnvServerManager.createLocal(EnvServerManager.java)
            at com.caucho.ejb.EjbServerManager.<init>(EjbServerManager.java:142)
            at com.caucho.ejb.EjbServerManager.createLocal(EjbServerManager.java)
            at com.caucho.ejb.EJBCompiler.compile(EJBCompiler.java:113)
            at com.caucho.ejb.EJBCompiler.main(EJBCompiler.java:147)
Caused by: com.caucho.config.ConfigException: Can't load TransactionManager.
            at com.caucho.ejb.xa.EjbTransactionManager.<init>(EjbTransactionManager.java:116)
            at com.caucho.ejb.EnvServerManager.<init>(EnvServerManager.java:147)
            ... 5 more
 
 
Additional Information
Attached Files

- Relationships

There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
04-28-05 00:00 ferg New Issue
11-01-05 00:00 administrator Fixed in Version  => 3.0.14
11-01-05 14:44 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
27 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker