Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000126 [Resin] minor always 04-28-05 00:00 11-02-05 14:44
Reporter ferg View Status public  
Assigned To
Priority high Resolution fixed  
Status closed   Product Version 3.0.12
Summary 0000126: EJB null pointer in configureAmber
Description RSN-117
(rep by Kirk Rasmussen)

 
[11:26:20.306] com.caucho.config.LineConfigException: /WEB-INF/cmp-xdoclet.ejb:131: null
[11:26:20.306] at com.caucho.ejb.cfg.EjbEntityBean.configureAmber(EjbEntityBean.java:888)
[11:26:20.306] at com.caucho.ejb.cfg.EjbConfig.configure(EjbConfig.java:395)
[11:26:20.306] at com.caucho.ejb.EjbServerManager.build(EjbServerManager.java:544)
[11:26:20.306] at com.caucho.ejb.EjbServerManager.init(EjbServerManager.java:530)
[11:26:20.306] at com.caucho.ejb.EJBServer.manualInit(EJBServer.java:588)
[11:26:20.306] at com.caucho.ejb.EJBServer.init(EJBServer.java:520)

(see email dated Apr 27)
Additional Information
Attached Files

- Relationships

- Notes
(0000150)
sam
04-28-05 00:00

(rep by R Mann)

Also seeing the same problem, cmp.ejb is attached.
 
(0000151)
ferg
04-28-05 00:00

[11:26:20.306] Caused by: java.lang.NullPointerException
[11:26:20.306] at com.caucho.ejb.cfg.CmrManyToOne.calculateColumns(CmrManyToOne.java:275)
[11:26:20.306] at com.caucho.ejb.cfg.CmrManyToOne.createId(CmrManyToOne.java:224)
[11:26:20.306] at com.caucho.ejb.amber.AmberConfig.configureId(AmberConfig.java:218)
[11:26:20.306] at com.caucho.ejb.amber.AmberConfig.addBean(AmberConfig.java:169)
[11:26:20.306] at com.caucho.ejb.cfg.EjbEntityBean.configureAmber(EjbEntityBean.java:884)
[11:26:20.306] ... 29 more
 
(0000152)
ferg
04-28-05 00:00

EjbConfig.BeanComparator.compareTo needs to be a total ordering for the bean sorting to work.
 

- Issue History
Date Modified Username Field Change
04-28-05 00:00 ferg New Issue
11-02-05 00:00 administrator Fixed in Version  => 3.0.14
11-02-05 14:44 ferg Status resolved => closed


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
29 unique queries executed.
Powered by Mantis Bugtracker