Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000915 [Resin] minor always 02-03-06 04:50 04-10-06 15:08
Reporter teemupo View Status public  
Assigned To ferg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.0.19 Product Version 3.0.17
  Product Build
Summary 0000915: Socket JNI library is not available
Description We have compiled Resin pro 3.0.17 with the following parameters:

./configure --prefix=/usr/local/resin-pro-3.0.17 --enable-jni --disable-ssl --enable-linux-smp --with-java-home=/usr/local/j2sdk1.4.2_08

The installation goes through without errors and it seems to find JNI without problems.

Part of configuration output:
checking for JNI in /usr/local/j2sdk1.4.2_08/include/linux ... found

Part of make output:
make[2]: Entering directory `/home/teemupo/resin-pro-3.0.17/modules/c/src/resin_os'
gcc -g -O2 -DPOLL -DB64 -m64 -fPIC -DRESIN_HOME=\"/home/teemupo/resin-pro-3.0.17\" -I/usr/local/j2sdk1.4.2_08/include -I/usr/local/j2sdk1.4.2_08/include/linux -I../common -DCPU=\"x86_64\" -DOS= -c -o jni_os.o jni_os.c
gcc -g -O2 -DPOLL -DB64 -m64 -fPIC -DRESIN_HOME=\"/home/teemupo/resin-pro-3.0.17\" -I/usr/local/j2sdk1.4.2_08/include -I/usr/local/j2sdk1.4.2_08/include/linux -I../common -DCPU=\"x86_64\" -DOS= -c -o jni_jvmti.o jni_jvmti.c
gcc -g -O2 -DPOLL -DB64 -m64 -fPIC -DRESIN_HOME=\"/home/teemupo/resin-pro-3.0.17\" -I/usr/local/j2sdk1.4.2_08/include -I/usr/local/j2sdk1.4.2_08/include/linux -I../common -DCPU=\"x86_64\" -DOS= -c -o jni_jvmdi.o jni_jvmdi.c
/usr/bin/ld -shared -fPIC -o jni_os.o jni_jvmti.o jni_jvmdi.o -lpthread

But we still get the following complain into stdout.log when starting the server:

Resin-3.0.17 (built Thu, 22 Dec 2005 12:11:34 PST)
Copyright(c) 1998-2004 Caucho Technology. All rights reserved.

Starting Resin on Fri, 03 Feb 2006 12:36:09 +0100 (CET)

[12:36:10.969] Proxy Cache disk-size=1024M memory-size=8M
[12:36:11.066] Server[fr2] starting
[12:36:11.090] Socket JNI library is not available.
[12:36:11.090] Resin will still run but performance will be slower.
[12:36:11.090] To compile the Socket JNI library on Unix, use ./configure; make; make install.

Here are some details about the environment:

$ uname -a
Linux deih30208038-25 2.6.9-22.0.1.ELsmp 0000001 SMP Tue Oct 18 18:39:02 EDT 2005 x86_64 x86_64 x86_64 GNU/Linux

$ cat /etc/redhat-release
Red Hat Enterprise Linux ES release 4 (Nahant Update 2)
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
02-13-06 11:21
edited on: 02-13-06 11:24

I am new to Linux/ Resin. How did you do:
./configure --prefix=/usr/local/resin-pro-3.0.17 --enable-jni --disable-ssl --enable-linux-smp --with-java-home=/usr/local/j2sdk1.4.2_08

Could you explain little more on that.

02-15-06 10:08

I have similar problems on Solaris 10 on AMD64. I turned the debug level up to "finest" and it looks like a problem with shared libraries -- I get " wrong ELF class: ELFCLASS64" if I run Resin using the standard start script, or " internal: message buffer overflow" if I tell the start script to run the JVM in 64-bit mode.

- Issue History
Date Modified Username Field Change
02-03-06 04:50 teemupo New Issue
02-13-06 11:21 anonymous Note Added: 0000880
02-13-06 11:24 anonymous Note Edited: 0000880
02-15-06 10:05 koreth Issue Monitored: koreth
02-15-06 10:08 koreth Note Added: 0000882
04-10-06 15:08 ferg Assigned To  => ferg
04-10-06 15:08 ferg Status new => closed
04-10-06 15:08 ferg Resolution open => fixed
04-10-06 15:08 ferg Fixed in Version  => 3.0.19

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
35 total queries executed.
29 unique queries executed.
Powered by Mantis Bugtracker