Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006149 [Resin] major always 03-01-18 11:17 03-12-18 17:07
Reporter wileysaw View Status public  
Assigned To ferg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 4.0.56 Product Version 4.0.55
  Product Build
Summary 0006149: a fault occurred in a recent unsafe memory access operation in compiled Java code
Description One node in a two cluster deployment continuously restarts with the following message:


WARNING com.caucho.server.resin.Resin - java.lang.InternalError: a fault occurred in a recent unsafe memory access operation in compiled Java code
                                                    at com.caucho.db.io.StoreReadWriteMmapNio$OutStoreMmapNio.write(StoreReadWriteMmapNio.java:919)
                                                    at com.caucho.db.io.StoreReadWriteMmapNio$OutStoreFacade.write(StoreReadWriteMmapNio.java:814)
                                                    at com.caucho.db.io.RandomAccessStreamNio.write(RandomAccessStreamNio.java:171)
                                                    at com.caucho.db.block.BlockReadWrite.extendFile(BlockReadWrite.java:397)
                                                    at com.caucho.db.block.BlockReadWrite.openRowFile(BlockReadWrite.java:333)
                                                    at com.caucho.db.block.BlockReadWrite.writeBlock(BlockReadWrite.java:278)
                                                    at com.caucho.db.block.BlockStore.create(BlockStore.java:495)
                                                    at com.caucho.server.httpcache.TempFileManager.<init>(TempFileManager.java:79)
                                                    at com.caucho.server.httpcache.TempFileService.createAndAddService(TempFileService.java:59)
                                                    at com.caucho.server.resin.ResinDelegate.addServices(ResinDelegate.java:222)
                                                    at com.caucho.server.resin.ProResinDelegate.addServices(ProResinDelegate.java:567)
                                                    at com.caucho.server.resin.Resin.initServletSystem(Resin.java:1321)
                                                    at com.caucho.server.resin.Resin.configure(Resin.java:1024)
                                                    at com.caucho.server.resin.Resin.initMain(Resin.java:1006)
                                                    at com.caucho.server.resin.Resin.main(Resin.java:1467)

Watchdog reports:

Watchdog detected close of Resin[bridge42,pid=43480]
                                                exit reason: UNKNOWN (exit code=13)
 {resin-30} java.lang.RuntimeException: java.net.SocketException: Socket closed
                                         at com.caucho.hmtp.HmtpLinkWorker.run(HmtpLinkWorker.java:117)
                                         at com.caucho.env.thread2.ResinThread2.runTasks(ResinThread2.java:173)
                                         at com.caucho.env.thread2.ResinThread2.run(ResinThread2.java:118)
                                     Caused by: java.net.SocketException: Socket closed
                                         at java.net.SocketInputStream.socketRead0(Native Method)
                                         at java.net.SocketInputStream.socketRead(SocketInputStream.java:116)
                                         at java.net.SocketInputStream.read(SocketInputStream.java:188)
                                         at java.net.SocketInputStream.read(SocketInputStream.java:141)
                                         at java.net.SocketInputStream.read(SocketInputStream.java:223)
                                         at com.caucho.remote.websocket.UnmaskedFrameInputStream.readFrameHeaderImpl(UnmaskedFrameInputStream.java:154)
                                         at com.caucho.remote.websocket.FrameInputStream.readFrameHeader(FrameInputStream.java:97)
                                         at com.caucho.remote.websocket.WebSocketInputStream.startBinaryMessage(WebSocketInputStream.java:77)
                                         at com.caucho.hmtp.HmtpWebSocketReader.readPacket(HmtpWebSocketReader.java:70)
                                         at com.caucho.hmtp.HmtpLinkWorker.run(HmtpLinkWorker.java:114)
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0006829)
wileysaw
03-06-18 19:22

This issue was caused by the /var directory running out of space. Cust has since configured the logs to output to a separate directory to avoid this restarting problem.
 

- Issue History
Date Modified Username Field Change
03-01-18 11:17 wileysaw New Issue
03-06-18 19:22 wileysaw Note Added: 0006829
03-12-18 17:07 ferg Assigned To  => ferg
03-12-18 17:07 ferg Status new => closed
03-12-18 17:07 ferg Resolution open => fixed
03-12-18 17:07 ferg Fixed in Version  => 4.0.56


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker