Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005179 [Resin] minor always 08-16-12 04:13 09-05-12 14:21
Reporter kiilerich View Status public  
Assigned To ferg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 4.0.31 Product Version 4.0.29
  Product Build
Summary 0005179: Setting cookies with maxAge(0) fails.
Description We've been trying to set a cookie with maxAge(0), path=/ to space (" ")..

However we get this result in the response headers:
Set-Cookie:WSS_ORDER_UUID=" "; Path="/"

Note the " signs around space and path. also note Path is spelled with capital P, and there is no expiration date set.

We've tried with empty cookie "", but no expires header either.

This works in Resin3 where it sets:

Set-Cookie:WSS_ORDER_UUID=; path=/; expires=Thu, 01-Dec-1994 16:00:00 GMT

Steps To Reproduce
Additional Information We've worked around the problem by using response.setHeader(..), but this not pretty.

Also reproducable on Resin 4.0.18, others not tested.
Attached Files

- Relationships

- Notes
09-05-12 14:21


- Issue History
Date Modified Username Field Change
08-16-12 04:13 kiilerich New Issue
09-05-12 14:21 ferg Note Added: 0006040
09-05-12 14:21 ferg Assigned To  => ferg
09-05-12 14:21 ferg Status new => closed
09-05-12 14:21 ferg Resolution open => fixed
09-05-12 14:21 ferg Fixed in Version  => 4.0.31

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker