Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004644 [Resin] minor always 06-27-11 13:41 06-28-11 16:43
Reporter alex View Status public  
Assigned To ferg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 4.0.20 Product Version 4.0.19
  Product Build
Summary 0004644: ORA-24756: Transaction does not exist
Description rep by Takahiro Fukuda

check xa-log with oracle.

x(WARN): oracle.jdbc.xa.OracleXAException
oracle.jdbc.xa.OracleXAException
    at oracle.jdbc.xa.OracleXAResource.checkError(OracleXAResource.java:1050)
    at oracle.jdbc.xa.client.OracleXAResource.forget(OracleXAResource.java:823)
    at com.caucho.transaction.TransactionManagerImpl.recover(TransactionManagerImpl.java:364)
    at com.caucho.jca.UserTransactionProxy.recover(UserTransactionProxy.java:217)
    at com.caucho.jca.ConnectionPool.init(ConnectionPool.java:518)
    at com.caucho.sql.DBPool.init(DBPool.java:667)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at com.caucho.config.j2ee.PostConstructProgram.inject(PostConstructProgram.java:60)
    at com.caucho.config.type.BeanType.init(BeanType.java:226)
    at com.caucho.config.ConfigContext.configureChildNode(ConfigContext.java:522)
    at com.caucho.config.ConfigContext.configureAttribute(ConfigContext.java:327)
    at com.caucho.config.program.NodeBuilderChildProgram.inject(NodeBuilderChildProgram.java:56)
    at com.caucho.config.program.ContainerProgram.inject(ContainerProgram.java:80)
    at com.caucho.config.program.ConfigProgram.configure(ConfigProgram.java:61)
    at com.caucho.server.cluster.Cluster.startServer(Cluster.java:708)
    at com.caucho.server.cluster.ClusterServer.startServer(ClusterServer.java:542)
    at com.caucho.server.resin.Resin.start(Resin.java:703)
    at com.caucho.server.resin.Resin.initMain(Resin.java:1162)
    at com.caucho.server.resin.Resin.main(Resin.java:1365)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at jp.co.intra_mart.bin.server.core.WebApplicationServer.run(WebApplicationServer.java:259)
    at java.lang.Thread.run(Thread.java:619)
Caused by: java.sql.SQLException: ORA-24756: gUNV?&8706;?ǵ?&0000960;B(There is not a transaction.)

    at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:439)
    at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:388)
    at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:381)
    at oracle.jdbc.driver.T4CTTIfun.processError(T4CTTIfun.java:564)
    at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:436)
    at oracle.jdbc.driver.T4CTTIfun.doRPC(T4CTTIfun.java:186)
    at oracle.jdbc.driver.T4CTTIOtxen.doOTXEN(T4CTTIOtxen.java:168)
    at oracle.jdbc.driver.T4CXAResource.doTransaction(T4CXAResource.java:746)
    at oracle.jdbc.driver.T4CXAResource.kputxrec(T4CXAResource.java:809)
    at oracle.jdbc.driver.T4CXAResource.doForget(T4CXAResource.java:609)
    at oracle.jdbc.xa.client.OracleXAResource.forget(OracleXAResource.java:818)
    ... 26 more
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0005338)
ferg
06-28-11 16:43

this is a logging issue, not a functional one. This failure should be logged at fine level, not warning.
 

- Issue History
Date Modified Username Field Change
06-27-11 13:41 alex New Issue
06-28-11 16:43 ferg Note Added: 0005338
06-28-11 16:43 ferg Assigned To  => ferg
06-28-11 16:43 ferg Status new => closed
06-28-11 16:43 ferg Resolution open => fixed
06-28-11 16:43 ferg Fixed in Version  => 4.0.20


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
28 unique queries executed.
Powered by Mantis Bugtracker