Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003790 [Resin] minor always 11-28-09 09:36 11-01-09 11:18
Reporter alex View Status public  
Assigned To ferg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 4.0.3 Product Version 4.0.2
  Product Build
Summary 0003790: mod_caucho post problem with file upload
Description rep by Wesley Wu
Multi-Part request error when using HmuxRequest.

My resin 4.0.2 was behind an apache 2.1.x using CauchoRequest to forward all request for a virtual host to resin.

If I use 8080 port without apache, everything goes fine.

2009-11-28 13:14:28.916 ERROR [server-127.0.0.1:6800-5] c.b.c.s.MultiPartRequest (103) - Unable to parse request
org.apache.commons.fileupload.FileUploadBase$IOFileUploadException: Processing of multipart/form-data request failed. Stream ended unexpectedly
    at org.apache.commons.fileupload.FileUploadBase.parseRequest(FileUploadBase.java:367) [FileUploadBase.class:1.2.1]
    at com.buysou.cms.servlet.JakartaMultiPartRequest.parse(JakartaMultiPartRequest.java:61) [classes:na]
    at com.buysou.cms.servlet.MultiPartRequestWrapper.<init>(MultiPartRequestWrapper.java:47) [classes:na]
    at com.buysou.cms.servlet.CmsPageFilter.wrapRequest(CmsPageFilter.java:268) [classes:na]
    at com.buysou.cms.servlet.CmsPageFilter.doFilter(CmsPageFilter.java:138) [classes:na]
    at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:88) [resin.jar:4.0.2]
    at com.buysou.servlet.filters.encoding.EnhancedEncodingFilter.doFilter(EnhancedEncodingFilter.java:85) [classes:na]
    at com.caucho.server.dispatch.FilterFilterChain.doFilter(FilterFilterChain.java:88) [resin.jar:4.0.2]
    at com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:183) [resin.jar:4.0.2]
    at com.caucho.server.cache.CacheFilterChain.doFilter(CacheFilterChain.java:169) [pro.jar:4.0.2]
    at com.caucho.server.webapp.AccessLogFilterChain.doFilter(AccessLogFilterChain.java:103) [resin.jar:4.0.2]
    at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:290) [resin.jar:4.0.2]
    at com.caucho.server.hmux.HmuxRequest.handleInvocation(HmuxRequest.java:475) [resin.jar:4.0.2]
    at com.caucho.server.hmux.HmuxRequest.handleRequestImpl(HmuxRequest.java:394) [resin.jar:4.0.2]
    at com.caucho.server.hmux.HmuxRequest.handleRequest(HmuxRequest.java:357) [resin.jar:4.0.2]
    at com.caucho.server.port.TcpConnection.handleRequestsImpl(TcpConnection.java:619) [resin.jar:4.0.2]
    at com.caucho.server.port.TcpConnection.handleRequests(TcpConnection.java:556) [resin.jar:4.0.2]
    at com.caucho.server.port.TcpConnection$AcceptTask.doTask(TcpConnection.java:1194) [resin.jar:4.0.2]
    at com.caucho.server.port.TcpConnection$ConnectionReadTask.runThread(TcpConnection.java:1127) [resin.jar:4.0.2]
    at com.caucho.server.port.TcpConnection$AcceptTask.run(TcpConnection.java:1158) [resin.jar:4.0.2]
    at com.caucho.util.ThreadPool$PoolThread.runTasks(ThreadPool.java:901) [resin.jar:4.0.2]
    at com.caucho.util.ThreadPool$PoolThread.run(ThreadPool.java:866) [resin.jar:4.0.2]
Caused by: org.apache.commons.fileupload.MultipartStream$MalformedStreamException: Stream ended unexpectedly
    at org.apache.commons.fileupload.MultipartStream$ItemInputStream.makeAvailable(MultipartStream.java:983) [MultipartStream$ItemInputStream.class:1.2.1]
    at org.apache.commons.fileupload.MultipartStream$ItemInputStream.read(MultipartStream.java:887) [MultipartStream$ItemInputStream.class:1.2.1]
    at java.io.InputStream.read(InputStream.java:85) [na:1.6.0_14]
    at org.apache.commons.fileupload.util.Streams.copy(Streams.java:94) [Streams.class:1.2.1]
    at org.apache.commons.fileupload.util.Streams.copy(Streams.java:64) [Streams.class:1.2.1]
    at org.apache.commons.fileupload.FileUploadBase.parseRequest(FileUploadBase.java:362) [FileUploadBase.class:1.2.1]
    ... 21 common frames omitted
Steps To Reproduce
Additional Information
Attached Files

- Relationships
related to 0003791closed ferg mod_caucho posts no data 

- Notes
(0004314)
ferg
11-01-09 11:18

server/264i
 

- Issue History
Date Modified Username Field Change
11-28-09 09:36 alex New Issue
11-28-09 09:42 alex Relationship added related to 0003791
11-01-09 11:18 ferg Status new => assigned
11-01-09 11:18 ferg Assigned To  => ferg
11-01-09 11:18 ferg Note Added: 0004314
11-01-09 11:18 ferg Status assigned => closed
11-01-09 11:18 ferg Resolution open => fixed
11-01-09 11:18 ferg Fixed in Version  => 4.0.3


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
33 total queries executed.
28 unique queries executed.
Powered by Mantis Bugtracker