Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003784 [Resin] minor always 11-24-09 13:52 12-10-09 10:56
Reporter ferg View Status public  
Assigned To alex
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 4.0.3 Product Version
  Product Build
Summary 0003784: win32 -install issue
Description (can be worked around by starting Resin from the command-line.)

There is an error on windows that I missed:

On a clean install: resin.exe -install; net start Resin will fail with

                        Caused by: com.caucho.sql.SQLExceptionWrapper: Cannot create directory: C:\appservers\resin-pro-4.0.2\watchdog-data
                              at com.caucho.db.sql.CreateQuery.execute(
                              at com.caucho.db.jdbc.StatementImpl.executeUpdate(
                              at com.caucho.db.jdbc.StatementImpl.executeUpdate(
                              at com.caucho.server.distcache.MnodeStore.initDatabase(
                              at com.caucho.server.distcache.MnodeStore.init(
                              at com.caucho.server.distcache.MnodeStore.<init>(
                              at com.caucho.server.distcache.AbstractDataCacheManager.<init>(
                              ... 7 more
                          Caused by: Cannot create directory: C:\appservers\resin-pro-4.0.2\watchdog-data
                              at com.caucho.vfs.FilePath.mkdirs(
                              at com.caucho.db.table.Table.create(
                              at com.caucho.db.table.TableFactory.create(
                              at com.caucho.db.sql.CreateQuery.execute(
                              ... 13 more
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
12-10-09 10:56

This appeared to be an environment issue that went away after windows was rebooted. Fresh installs after reboot worked fine.

- Issue History
Date Modified Username Field Change
11-24-09 13:52 ferg New Issue
11-25-09 03:30 hans Issue Monitored: hans
12-10-09 10:54 alex Status new => assigned
12-10-09 10:54 alex Assigned To  => alex
12-10-09 10:56 alex Status assigned => closed
12-10-09 10:56 alex Note Added: 0004327
12-10-09 10:56 alex Resolution open => fixed
12-10-09 10:56 alex Fixed in Version  => 4.0.3

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
31 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker