Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003551 [Quercus] major always 06-07-09 09:43 06-08-09 05:19
Reporter Jose View Status public  
Assigned To
Priority normal Resolution open Platform
Status new   OS
Projection none   OS Version
ETA none Fixed in Version Product Version 3.2.1
  Product Build
Summary 0003551: Potential Encoding issues preventing the appropriate display of essential features in blog software b2evolution.
Description I have tried Quercus included in Resin 3.1.9 as well as the Quercus module quercus-3.2.1.war on the IBM WebSphere Application Server Community Edition (WASCE) version MySQL Connector 3.1.14 and MySQL Connector 5.1.7 have been tried in Resin 3.1.9; the latter has been tried on WASCE.

Installation of b2evolution 2.4.7 and 3.x and connection to MySQL database (mysql Ver 14.12 Distrib 5.0.81, for debian-linux-gnu (i486) using readline 5.2) are successful. Upon the first login screen I Resin 3.1.9 shows the error:

500 Servlet Exception

[show] com.caucho.quercus.QuercusExecutionException: com.caucho.quercus.UnimplementedException
`mb_detect_encoding' has not been implemented.
[and a long Java exception error log]

Notwithstanding trying once again to enter the administration log screen, I am able to log in. Notwithstanding issues like those below (also see snapshot),

string::1: Warning: required argument missing [disp_coll_name] string::1: Warning: required argument missing [disp_coll_name] string::1: Warning: required argument missing [strmaxlen] admin string::1: Warning: required argument missing [disp_actions] PropertiesEditDel

are prevalent which leads me to suspect ISO-8859-1 / UTF-8 related issues. I have tried setting explicitly both encodings in file php/quercus-war/WEB-INF/web.xml but the blog application visual results are the same nonetheless.

I might mention that I have attempted to disable `mb_detect_encoding' in b2evolution inc/_ext/xmlrpc/ (which is derived from [^] with not noticeable outcome.
Steps To Reproduce
Additional Information
Attached Files  resin-3.1.9_06-07-2009.png [^] (151,153 bytes) 06-07-09 09:43
 resin-3.2.1_06-07-2009.png [^] (237,638 bytes) 06-08-09 05:19

- Relationships

- Notes
06-07-09 10:08
edited on: 06-08-09 05:21

If the attached png files are unreadable, please see links where I uploaded those same: [^] [^]


- Issue History
Date Modified Username Field Change
06-07-09 09:43 Jose New Issue
06-07-09 09:43 Jose File Added: resin-3.1.9_06-07-2009.png
06-07-09 10:08 Jose Note Added: 0004061
06-07-09 10:12 Jose Issue Monitored: Jose
06-08-09 05:19 Jose File Added: resin-3.2.1_06-07-2009.png
06-08-09 05:21 Jose Note Edited: 0004061

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
32 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker