Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002535 [Resin] minor always 03-18-08 08:24 03-24-08 12:28
Reporter ferg View Status public  
Assigned To ferg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.1.6 Product Version
  Product Build
Summary 0002535: hessian 2 bytes
Description (rep by Ray Erdelyan)

I receive the error when trying to transfer files using code similar to
the "Hessian with large binary data" example. I am using version 3.1.5.
I found a post listing the same error dated: Wed Jan 23 01:59:32 CST
2008 -- Bug Report: buffered reading error in hessian3.1.3.jar --
tedeyang at
I followed their suggestion and it solved my problem, but I could find
nothing in the bug list. Here is the fix explained in more detail.

class= Hessian2Input extends AbstractHessianInput implements

method= int read(byte[] buffer, int offset, int length) throws IOException

               ---------- code omitted for brevity ---------

               switch (code)
               case 'b':
                   _isLastChunk = false;
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
03-24-08 12:28


- Issue History
Date Modified Username Field Change
03-18-08 08:24 ferg New Issue
03-24-08 12:28 ferg Note Added: 0002882
03-24-08 12:28 ferg Assigned To  => ferg
03-24-08 12:28 ferg Status new => closed
03-24-08 12:28 ferg Resolution open => fixed
03-24-08 12:28 ferg Fixed in Version  => 3.1.6

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker