Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002528 [Resin] minor always 03-14-08 13:06 03-25-08 14:10
Reporter ferg View Status public  
Assigned To ferg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.1.6 Product Version 3.1.5
  Product Build
Summary 0002528: amber initialization order
Description (rep by Riccardo Cohen)

I have one single entity ejb :

package adlejb;
public class Ejbuser
 @Id @Column(name="adlid") @GeneratedValue int id;
 @Basic @Column(name="adlfirstname") String firstname;
 @Basic @Column(name="adlname") String name;

and the config in persistence.xml is :

<persistence xmlns="" [^] version="1.0">
 <persistence-unit name="Adlhessian">
   <exclude-unlisted-classes />

But I continue to have the error =

com.caucho.amber.AmberRuntimeException: 'adlejb.Ejbuser' with classloader EnvironmentClassLoader[web-app:http://localhost:8000] [^] is an illegal instance class

What does it mean ? I found no error, and tried to have a look at mailinglist archive with no success. I looked at the samples, but found nothing really different...

The crazy about this is that I built this simple app from another simple app configured exactly the same manner, but the other does not make any amber error ! I tried to rename everything several times, but nothing seems to remove this error. I had the same problem sometimes with resin 3.0 and in 2006 Rodrigo Westrupp answered that I should work with resin 3.1.

Steps To Reproduce <persistence xmlns="" [^] version="1.0">
 <persistence-unit name="Adlhessian">
   <exclude-unlisted-classes />
<web-app xmlns=""> [^]
 <database jndi-name="jdbc/adlhessian">
     <url>jdbc:mysql://localhost/adlhessian</url> [^]
     <init-param autoReconnect="true"/>
     <init-param noDatetimeStringSync="true"/>
     <init-param jdbcCompliantTruncation="false"/>
 <ejb-server data-source="jdbc/adlhessian" create-database-schema="false"/>
 <servlet servlet-name="adlservice" servlet-class="adlhessian.Adlservice"/>
 <servlet-mapping url-pattern="/adlservice/*" servlet-name="adlservice"/>

Additional Information
Attached Files

- Relationships

- Notes
03-25-08 14:10


- Issue History
Date Modified Username Field Change
03-14-08 13:06 ferg New Issue
03-25-08 14:10 ferg Note Added: 0002895
03-25-08 14:10 ferg Assigned To  => ferg
03-25-08 14:10 ferg Status new => closed
03-25-08 14:10 ferg Resolution open => fixed
03-25-08 14:10 ferg Fixed in Version  => 3.1.6

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
28 total queries executed.
25 unique queries executed.
Powered by Mantis Bugtracker