Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002335 [Quercus] major always 01-15-08 14:06 01-28-08 16:30
Reporter mo View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.1.5 Product Version 3.1.5
  Product Build
Summary 0002335: non-ascii characters in PHP identifier cause parser error
Description This bug report comes from a Forum post:

http://forum.caucho.com/index.php?q=node/132 [^]

The root of the problem is that a PHP file that contains
a non-ascii character in a variable name will not be parsed
correctly by Quercus.

$Lšnge = 1;

The above line of PHP code generates the following error:

"/tmp/caucho/qa/test.php:7: unknown lexeme:&0000931; in ..."
Steps To Reproduce
Additional Information Added the following QA tests:

php/0039.qa
php/003a.qa

The 003a.qa test is a bit tricky because the file is written
to disk in a UTF-8 encoding.
Attached Files

- Relationships

- Notes
(0002693)
mo
01-28-08 16:28

Regression tests added to cover this issue:

php/0i19.qa:
php/0j19.qa:
php/3i19.qa:
php/3j19.qa: Unicode semantics for file in memory.
php/0i1a.qa:
php/0j1a.qa:
php/3i1a.qa:
php/3j1a.qa: Unicode semantics for file on disk.
php/0i1b.qa:
php/0j1b.qa:
php/3i1b.qa:
php/3j1b.qa: Output encoding test for string.
php/0ik0.qa:
php/0jk0.qa:
php/3ik0.qa:
php/3jk0.qa: Non-ascii in iso-8859-1 encoding.
php/0ik1.qa:
php/0jk1.qa:
php/3ik1.qa:
php/3jk1.qa: Non-ascii in UTF-8 encoding.
 
(0002694)
mo
01-28-08 16:30

Non-ascii identifiers in PHP should now be working as
expected.
 

- Issue History
Date Modified Username Field Change
01-15-08 14:06 mo New Issue
01-25-08 12:34 mo Note Added: 0002683
01-28-08 16:27 mo Note Deleted: 0002683
01-28-08 16:28 mo Note Added: 0002693
01-28-08 16:30 mo Status new => closed
01-28-08 16:30 mo Note Added: 0002694
01-28-08 16:30 mo Resolution open => fixed
01-28-08 16:30 mo Fixed in Version  => 3.1.5


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
33 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker