Mantis Bugtracker

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001936 [Quercus] major always 08-13-07 06:33 08-13-07 15:03
Reporter dberry View Status public  
Assigned To nam
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.1.3 Product Version 3.1.1
  Product Build
Summary 0001936: Cannot send response error with Quercus
Description Tried header('HTTP/1.0 403 Forbidden');
and browser displayed a white screen with no error message

Tried using global $respone, $response->sendError(403); and got the following message: Fatal Error: 'com.caucho.server.http.HttpRequest::sendError' is an unknown method

Looks like $respone is getting set to the Request.
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
08-13-07 15:03


Quercus does send the desired response header, but tt does not send a default error page, which matches the behavior of PHP. The user app is responsible for sending output.

For $response, yes it was being set to HttpRequest by mistake. It only affects Quercus under Resin.

- Issue History
Date Modified Username Field Change
08-13-07 06:33 dberry New Issue
08-13-07 14:53 nam Status new => assigned
08-13-07 14:53 nam Assigned To  => nam
08-13-07 15:03 nam Status assigned => closed
08-13-07 15:03 nam Note Added: 0002197
08-13-07 15:03 nam Resolution open => fixed
08-13-07 15:03 nam Fixed in Version  => 3.1.3

Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker