Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000146 [Resin] minor always 05-06-05 00:00 01-27-06 11:02
Reporter prakashhegde View Status public  
Assigned To ferg
Priority high Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.0.18 Product Version
  Product Build 3.0.13
Summary 0000146: NPE in JSF webapp (at startup)
Description RSN-140
First time when the JSF webapp (cardemo) is deployed, webapp starts fine. However, on Resin re-start the webapp re-start fails w/ an NPE. Attched is the resin.conf and webapp-default.xml (zipped up).

Workaround: Remove the WEB-INF\work folder to get the webapp start up correctly again.
Steps To Reproduce
Additional Information JDK142_08, Resin 3.0.12 and also tried it on Resin snapshot for 3.0.13, Linux RH 9 and Win XP.
Attached Files

- Relationships

- Notes
(0000801)
ferg
01-27-06 11:02

JSF requires the .tld loading to happen at startup time, not lazily
 

- Issue History
Date Modified Username Field Change
05-06-05 00:00 prakashhegde New Issue
01-27-06 11:02 ferg Note Added: 0000801
01-27-06 11:02 ferg Assigned To  => ferg
01-27-06 11:02 ferg Status acknowledged => closed
01-27-06 11:02 ferg Resolution open => fixed
01-27-06 11:02 ferg version 3.0.13 =>
01-27-06 11:02 ferg Fixed in Version  => 3.0.18


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
30 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker