Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001131 [Quercus] major always 05-19-06 14:14 05-01-06 10:54
Reporter koreth View Status public  
Assigned To ferg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.0.20 Product Version 3.0.20
  Product Build
Summary 0001131: MySQL queries fail with ClassCastException
Description I haven't figured out exactly the circumstances that cause this. My best guess is that it's when a MySQL query returns no results. But in any case, sometimes queries fail with the following exception:

[14:00:39.625] java.lang.ClassCastException: com.caucho.quercus.env.BooleanValue
[14:00:39.625] at com.caucho.quercus.lib.mysql.Mysqli.query(Mysqli.java:401)
[14:00:39.625] at com.caucho.quercus.lib.mysql.MysqlModule.mysql_query(MysqlModule.java:377)

It looks like JdbcConnectionResource.query() is returning a BooleanValue in some cases, which the code is trying to cast to a JavaValue.
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0001255)
ferg
05-01-06 10:54

php/141d
 

- Issue History
Date Modified Username Field Change
05-19-06 14:14 koreth New Issue
05-01-06 10:54 ferg Note Added: 0001255
05-01-06 10:54 ferg Assigned To  => ferg
05-01-06 10:54 ferg Status new => closed
05-01-06 10:54 ferg Resolution open => fixed
05-01-06 10:54 ferg Fixed in Version  => 3.0.20


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
29 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker