Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000111 [Resin] minor always 04-20-05 00:00 03-30-06 14:45
Reporter cbraunstein View Status public  
Assigned To ferg
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.0.18 Product Version
  Product Build 3.0.12
Summary 0000111: CachedRowSet does not work with JDK 1.5
Description RSN-102
On JDK 1.4.2 with the rowset 1.0.1 jar the following JSP runs fine:

<%@ page language="java" import="com.sun.rowset.*"%>
<%
    CachedRowSetImpl crs = new CachedRowSetImpl();
%>

Using JDK 1.5 that JSP gives the following error:

java.lang.NullPointerException
    at java.util.Properties$LineReader.readLine(Properties.java:365)
    at java.util.Properties.load(Properties.java:293)
    at java.util.PropertyResourceBundle.<init>(PropertyResourceBundle.java:96)
    at com.sun.rowset.JdbcRowSetResourceBundle.<init>(JdbcRowSetResourceBundle.java:102)
    at com.sun.rowset.JdbcRowSetResourceBundle.getJdbcRowSetResourceBundle(JdbcRowSetResourceBundle.java:119)
    at com.sun.rowset.CachedRowSetImpl.<init>(CachedRowSetImpl.java:336)
    at _jsp._test__jsp._jspService(test.jsp:3)
    at com.caucho.jsp.JavaPage.service(JavaPage.java:63)
    at com.caucho.jsp.Page.pageservice(Page.java:570)
    at com.caucho.server.dispatch.PageFilterChain.doFilter(PageFilterChain.java:159)
    at com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:163)
    at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:208)
    at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:259)
    at com.caucho.server.port.TcpConnection.run(TcpConnection.java:341)
    at com.caucho.util.ThreadPool.runTasks(ThreadPool.java:467)
    at com.caucho.util.ThreadPool.run(ThreadPool.java:408)
    at java.lang.Thread.run(Thread.java:595)
Steps To Reproduce
Additional Information JDK 1.4.2_08 VS JDK 1.5.0_02 on Win 2003
Attached Files

- Relationships

- Notes
(0000127)
ferg
04-20-05 00:00

At first glance, this looks like a JDK issue (though classloading is possible). That example works on a test.jsp on Unix.
 
(0000128)
cbraunstein
04-20-05 00:00

Any progress on this issue?
 
(0000129)
cbraunstein
04-20-05 00:00

Doesn't work in sun JDK 5_04 either nor in JRockit 5_03
 
(0000130)
cbraunstein
04-20-05 00:00

The problem is JDK install location with spaces in them. Since JDK5 defaults to c:\program files\java - it causes the error. Install in a directory without spaces and it fixes it.
 
(0000976)
ferg
03-30-06 14:45

fixed together with the spaces issues on windows.
 

- Issue History
Date Modified Username Field Change
04-20-05 00:00 cbraunstein New Issue
03-30-06 14:45 ferg Note Added: 0000976
03-30-06 14:45 ferg Assigned To  => ferg
03-30-06 14:45 ferg Status acknowledged => closed
03-30-06 14:45 ferg Resolution open => fixed
03-30-06 14:45 ferg version 3.0.12 =>
03-30-06 14:45 ferg Fixed in Version  => 3.0.18


Mantis 1.0.0rc3[^]
Copyright © 2000 - 2005 Mantis Group
34 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker