Mantis - Resin
Viewing Issue Advanced Details
5830 minor always 11-21-14 04:29 03-31-15 14:11
closed 4.0.41  
none 4.0.43  
0005830: Running Atmosphere within Resin 4
I'm trying to run atmosphere framework within Resin 4 application server but has encountered some problems. I've build atmosphere-chat war from sample sources and deployed it. When I've opened it in browser following exception has been occurred.

Looks like it failed while using fallback long-polling transport. I'he also tried this example with other transports and other examples (atmosphere-chat-sse, atmosphere-ee6) but without success - exception disappeared but messages not came. I've tried to run same examples within glassfish and everything works fine.

According to related google groups topic (!topic/atmosphere-framework/dA2JVfGZFic) [^] it could be a bug in Resin 4.

Related issue at atmosphere framework bug tracker - [^]

Sample atmosphere-chat uses atmosphere framework 2.3.0-SNAPSHOT version, but problem also reproduces with 2.2.3 version.
Resin version - 4.0.41
 atmosphere-chat.log [^] (31,623 bytes) 11-21-14 04:29

11-24-14 02:18   
Issue at atmosphere bug tracker ( [^] has been implemented. Not reproduces any more after that.
11-24-14 18:45   
gf ignores header if value is null
12-18-14 13:15   
We tentatively fixed this issue for 4.0.42: [^]