Mantis - Resin
Viewing Issue Advanced Details
4693 crash always 08-02-11 00:31 08-12-11 10:51
closed 4.0.20  
none 4.0.21  
0004693: Resin 4.0.20 crashed when run with project and apache
Following error is received when run in console. Just to confirm installation issues, I ran resin outside my project and it works. I confirmed all environment variables Java, Project directory, Resin home, etc and they are correct.

Seems to failed due to some file path may be but not sure what could cause this issue. I confirmed resin.jar and resin.conf is present at said address.

# A fatal error has been detected by the Java Runtime Environment:
# SIGSEGV (0xb) at pc=0x00002aaaf4ef06a7, pid=4503, tid=1105049920
# JRE version: 6.0_17-b04
# Java VM: Java HotSpot(TM) 64-Bit Server VM (14.3-b01 mixed mode linux-amd64 )
# Problematic frame:
# C [] Java_com_caucho_vfs_JniFilePathImpl_nativeCanRead+0x27
# An error report file with more information is saved as:
# /root/shivaji_workspace/trunk/Project/hs_err_pid4503.log
# If you would like to submit a bug report, please visit:
# [^]
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
/root/shivaji_workspace/trunk/Project/startapp: line 48: 4503 Aborted ${JAVA_HOME}/bin/java -jar ${RESIN_HOME}/lib/resin.jar -resin-home ${RESIN_HOME} -server ${IPADDRESS} -root-directory ${SERVER_ROOT} -conf ${SERVER_ROOT}/resin.conf $1
resin startup failed, stopping resin

PL/SQL procedure successfully completed.

Above is command that is being run. I am on CentOS.

Note: Another version of resin on same machine works.

08-04-11 09:56   
Is this reproducible?

That JNI code hasn't changed, and a review of it doesn't show any issues.

You might try doublechecking that the libexec64/ was properly built for the same version of Resin as the resin.jar (and pro.jar, since pro.jar loads this file.)
08-04-11 21:39   
Yes it is reproducible every time. I tried switching JDK versions but it didn't help.

I see that the libexec64/ is present in resin. How do I make sure that it is built properly? Is there any command?
08-09-11 23:08   
I just recompiled the Resin and it worked for me.
08-12-11 10:51   
Eclipse plugin will now install new version of resin-pro into a version specific directory.