Mantis - Resin
Viewing Issue Advanced Details
3928 block always 03-06-10 17:43 08-05-10 09:11
closed 4.0.4  
none 4.0.10  
0003928: Neither resin.exe nor setup.exe run on 64-bit Windows Server 2003
I'm attempting to install Resin Pro 4.0.4 on a 64-bit Windows Server 2003 (SP2). But when attempting to run either setup.exe or resin.exe, neither will run. See the attached image file.

This is a blocker because I'm attempting to set up MediaWiki 1.15.1 with MySQL 5.1.44, along with importing our old MediaWiki database. I was able to do this successfully on my OS X box using Resin 4.0.4. But, obviously, I can't do it with Resin 4.x on Windows. And when I tried to do the same thing using Resin 3.1.10, I couldn't make it work. This appears to be due to issues/incompatibilities with Resin 3.1 and MySQL 5.1. I say this because there are a couple messages during the set up and when starting Resin that lead me to believe that, for some reason, Resin and/or MediaWiki think they are accessing MySQL 4.

In any event, I'd really like to try doing it with Resin Pro 4.x, but can't even get started. :(
 CoRDScreenSnapz001.png [^] (3,765 bytes) 03-06-10 17:43

03-09-10 15:22   
hmm. we are in the middle of rewriting resin.exe and setup.exe, but the pre-4.0.4 checkout with vista 64 did work, so we can take some extra time on that configuration for 4.0.5.

You can always use "java -jar lib/resin.jar start" and bypass resin.exe.
03-09-10 16:22   
I've given up on the wiki for the time being, but will return to it in a couple weeks.

It occurred to me that I could run it from the command line after giving up for the day (it was Saturday, after all!), but I had made other incompatible changes and didn't want to waste time backtracking. Anyway, in the long run, I'll still need resin.exe to work since this needs to run as a Windows Service.
03-10-10 14:33   
Another update. I tried this on a different machine which is also running Windows 2003 Server 64-bit SP2 and both programs work. Soooo, not sure what's going on. The only difference I can see between the two machines is that the one where it doesn't work is a VMWare instance and the one where it works is not a VM. I haven't done any tests on other machines to see if there's any kind of pattern.

The good news is, the machine where it DOES work is the machine I actually need to run Resin 4.x on, so this issue isn't a blocker for me any longer.
03-11-10 09:20   
The png file you've supplied is not valid. Can you re-upload the archived / zipped image again? thanks!
03-11-10 09:37   
Can you also make sure that .NET framework is up to version 3.5?
03-13-10 11:55   
The png file is just a picture of the error, says something like "Application terminated" and gives a hex memory address.

I don't see evidence that any version of .NET is installed on the machine where it doesn't work. On the one where it does work, it says that .NET 2.0 is installed.
08-05-10 09:11   
.NET 3.5 is required. .NET version check is added to setup.exe startup routine.