Mantis - Resin
Viewing Issue Advanced Details
2470 crash always 02-28-08 07:49 04-08-08 11:28
closed 3.1.5  
none 3.1.6  
0002470: RESIN 3.1.5 crashes when installed as NT Service in Windows XP SP2
I have observed fatal bug when I tried new version or Resin 3.1.5
OS: Windows XP Service Pack 2
Java Version: JDK-6 Update 4 ( Latest )
Confirmed on 3 separate machines.
First I installed resin as NT service at command prompt
httpd.exe -install

When I start resin service at command prompt NET START Resin
HTTPD.EXE crashes ! ( See attached Screen Shots )
I have tried this on three 3 separate machines, All having Windows XP SP2

Resin runs normally when started on command prompt as
HTTPD -Verbose
Sharad Kelkar
 resin-crash-screenshot.jpg [^] (43,125 bytes) 02-28-08 07:49
 Snap1.jpg [^] (118,386 bytes) 03-16-08 21:18

03-11-08 01:02   
I have a similar problem on Windows 2003 SP 2 with Resin 3.1.5. When starting the service I get
The Resin Web Server service is starting.

The Resin Web Server service could not be started.

A system error has occurred.

System error 1067 has occurred.

The process terminated unexpectedly.

Everything works fine when using the same command line without "-service" in a command window.
03-14-08 05:44   
I downloaded and installed Resin 3.1.5 two days ago and the same problem occurs for me when I start Resin as a service.

My system is a Windows XP SP2.

Resin works fine when started via the command line (not as service).

Note: I am using Resin with an Apache 2.2 Webserver.

Is there any clue of why Resin keeps crashing after being started as a service? Is there a configuration problem (e.g. some environment variable missing) or a JDK problem (I am using JDK 1.6)
03-16-08 21:06   
I have the same problem.
Windows 2003 SP2 + Resin3.1.5 + JDK1.5.0_11

03-24-08 00:16   
nobody notice this??!!
03-27-08 01:42   
I have similar problem. My environment is,
Windows XP Professional SP2 + Resin 3.1.5 + JDK 1.5.0_15
03-31-08 04:47   
I have the same problem with Resin 3.1.5 Professional, resin crashes when started as a service in windows server 2003 R2 Service Pack 2 with java 1.6.0_02.
03-31-08 08:37   
I' m running Resin 3.1.5 on Windows 2003 (SBS SP2).
JDK 1.6.0_03, Apache/2.0.59 (Win32) Resin/3.1.5 PHP/5.2.3
Everything runs smooth when I start httpd from command line.
It doens't work as a service.

The only error I can find on the server is in the application log: Faulting application httpd.exe, version, faulting module httpd.exe, version, fault address 0x00011399.

This looks more like a Apache error than a Resin error.
And there is nothing to see in the resin logs.

P.S. I installed an old version (resin 2.1.13) as test and that is running fine as a service.